You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
This repository was archived by the owner on Nov 19, 2022. It is now read-only.
brian barnes edited this page Jan 22, 2018
·
1 revision
Prerequisites
Their are certain prerequisites that you must meet in order for "RemotePlus" to operate properly.
You must have a "Configurations/Server" folder in the root of your "RemotePlus folder"
You must have a "Configurations/Email" folder in the root of your "RemotePlus folder"
In order for you to view the help documentation for a command, you must place all the help files into the "HelpDoc" folder.
you must have the .Net framework version 4.7 installed on the server and client computer.
You must have at least one NIC installed on the server.
What If I Don't Meet Those Requirements?
If you don't meet the prerequisites, the server will not start, and you will see an error during startup.
A prerequisite error would look like the following:
Welcome to RemotePlusServer, version: 1.0.0.0
1/22/2018 2:52:53 PM [Server Host][DEBUG]: Starting stop watch.
1/22/2018 2:52:53 PM [Server Host][INFO]: NOTE: Tracing may be enabled on the server.
1/22/2018 2:52:53 PM [Server Host][INFO]: Adding default known types.
1/22/2018 2:52:53 PM [Server Host][DEBUG]: Adding UserAccount to known type list.
1/22/2018 2:52:53 PM [Server Host][WARNING]: The server settings file does not exist. Creating server settings file.
1/22/2018 2:52:53 PM [Server Host][ERROR]: Internal server error: Could not find a part of the path 'D:\Source\Repos\RemotePlus\src\RemotePlusServer\bin\Debug\Configurations\Server\GlobalServerSettings.config'.
Press any key to exit.1/22/2018 2:52:53 PM [Server Host][INFO]: Saving log and closing.